FireGPG and Firefox 4

April 1, 2011 – 10:22 pm by Maximilien Cuony [The_glu]

Hello,

Unfortunaly, FireGPG won’t work in Firefox 4 because of the missing IPC library. There is no easy way to fix the problem. If you’re able to build a library (please see https://bugzilla.mozilla.org/show_bug.cgi?id=68702), feel free to post an howto !

Bests,

  1. 9 Responses to “FireGPG and Firefox 4”

  2. I am really missing fireGPG, can someone be paid to maintain this? Can something be done?

    By andrewmuck on May 20, 2011

  3. Yes, I represent a community that would be willing to fund continued development of this tool.

    I certainly hope that this project was not discontinued because of political or corporate pressure. This tool has been a very useful in the protection of individual privacy in the last few years.

    We definitely need a similar tool for other browsers, but right now Firefox is the best for freedom.

    By Admin on May 24, 2011

  4. I have Firefox 4 installed on Gentoo Linux and it claims to have built the IPC library, but FireGPG doesn’t work anyway.

    By Jack on May 31, 2011

  5. the bug link you sent is ‘resolved fixed’
    https://bugzilla.mozilla.org/show_bug.cgi?id=68702

    Now can anything be done easily? please reply.

    By Saga on Jun 5, 2011

  6. I’m reading that for Firefox 5 (released today), the IPC library is required:

    http://tenfourfox.blogspot.com/2011/05/four-ever-yours.html

    (Apparently it’s compiled in then?)

    I tried hacking the FireGPG .xpi’s maxversion to 5 to install it; it installed but couldn’t locate the IPC library when I ran it. Apparently it would need other work to be compatible or functional with firefox 5.

    I don’t know how to make that work; I’m hoping a visitor or this here thar original author of this plugin does.

    By Alex on Jun 22, 2011

  7. Can someone use the firefox add-on and create a grease monkey script for GNUPG/GPG4WIN, which would function like FireGPG when using Gmail?

    The only script grease monkey has close to this is this:

    http://www.langenhoven.com/code/emailencrypt/gmailencrypt.php

    Only thing is, it is weak encryption. But it does integrate nicely with Gmail.

    By Ditto on Jun 24, 2011

  8. The plugin was patched on the forked version on Github to work with FF 4.0.1:

    https://github.com/firegpg/firegpg

    However, Mozilla broke it again for FF5.

    By Scanman1 on Jun 28, 2011

  9. I posted about this on Slashdot, and the main site is now slashdotted:

    http://news.slashdot.org/comments.pl?sid=2277556&cid=36602002

    By Scanman1 on Jun 28, 2011

  10. FireGPG works on Firefox 5 now:

    https://grepular.com/FireGPG_on_Firefox_5

    By Mike on Jul 6, 2011

Post a Comment